升级Ruby后新版Jekyll应注意的问题

Dec 29, 2012

1. UTF-8编码问题

UTF-8编码不再被Jekyll编译(主要是YAML front matter无法解析UTF-8),只适用于UTF-8无bom格式

2. YAML 1.2 对 Collections 的格式改变

将不支持如下格式:

tags: 
-  Jekyll
-  Ruby

应改为:

tags: 
  Jekyll
  Ruby

参考文献

http://www.yaml.org/spec/1.2/spec.html